Skip to main content
Topic: cairoDevice (Read 3679 times) previous topic - next topic

cairoDevice

Hi,

I installed metaXCMS a few days ago and I have the following problem running it: before installing metaXCMS I completely removed R and all packages from my PC before reinstalling R, XCMS, metaXCMS and all dependencies. After the new installation metaXCMS worked fine the first time. However, after quitting R and starting a new metaXCMS session I got the following error:

> library(metaXCMS)
Loading required package: cairoDevice
Error in inDL(x, as.logical(local), as.logical(now), ...) :
  unable to load shared object 'C:/Program Files/R/R-2.13.1/library/cairoDevice/libs/i386/cairoDevice.dll':
  LoadLibrary failure:  The specified module could not be found.

Error: package 'cairoDevice' could not be loaded

Are there plans to integrate metaXCMS into the online version of XCMS?

Koen

Re: cairoDevice

Reply #1
Somebody told me about a similar problem a while ago.
Unfortunately, I don't know if and how it got fixed.

Can you try reinstalling cairoDevice ?
Code: [Select]
install.packages("cairoDevice")

Which Windows version are you using ?

And yes, we are planning to integrate metaXCMS into XCMS Online.

Re: cairoDevice

Reply #2
Hi Ralf,

I tried reinstallung the cairoDevice. Unfortunately this did however not solve the problem. I am using Windows XP professional 2002 SP3.

Koen

Re: cairoDevice

Reply #3
The problem is that the newer versions of RGtk2 install GTK+ locally within the RGtk folder (instead of installing it globally like the older version did)
so cairoDevice cannot find the GTK+ libraries anymore. 

So now the procedure of installing metaXCMS on Windows is:
    >1. Download and Install GTK+ 
http://downloads.sourceforge.net/gtk-win/gtk2-runtime-2.22.0-2010-10-21-ash.exe?download%27

2. Install cairoDevice and RGTK+ (from within R)
Code: [Select]
install.packages(c("cairoDevice","RGtk2","gstat","RANN","xlsx"))

3. Download metaXCMS .zip file from http://metlin.scripps.edu/metaxcms/download.php

4. Install the metaXCMS package using the downloaded .zip file ("Install package(s) from local zip files")

[/list]

Ralf

Re: cairoDevice

Reply #4
Update:
Michael Lawrence fixed the installation problem in cairoDevice version 2.17
Both, cairoDevice and RGtk2 will install their own GTK+ locally, if no GTK+ is found on the system.
This should work on 32 and 64 bit windows.