Skip to main content
Topic: xcms does not execute (Read 772 times) previous topic - next topic

xcms does not execute

I changed my computer and re-installed the whole packages, with the latest R version (3.5.1). Since then, xcms does not work anymore, remaining stacked at the first line

xset<-xcmsSet(method="centWave", peakwidth=c(3,20), snthresh=5, mzdiff=0.01, ppm=3, prefilter=c(5,100000), noise=20000, integrate=1)

a warning message indicate :
Scanning files in directory C:/users/.... (blablabla until the correct file directory).. found 99 files

I also tried with the old R version that I installed and that used to work, but no success either

I'm not a beginner with xcms, and I tried to process my files using another computer in the lab and everything is alright.

I'm using windows 10 with an dell computer equipped with a Xeon processor

any idea of what'sgoing wrong?

many thanks

Re: xcms does not execute

Reply #1
Eventually there is something strange going on with the parallel processing. Please add the following line right after you load the xcms package and retry:


with that you disable parallel processing - if it runs without parallel processing we can think of a way to fix parallel processing.

cheers, jo