Skip to main content
Topic: (Post)Alignment Processing - Blank filter option (Read 615 times) previous topic - next topic

(Post)Alignment Processing - Blank filter option

Hi,

I have a question regarding the (post-)alignment process, i.e. the option to filter „blank features“.
In the alignment settings, I checked the blank filter option using an average intensity ratio of sample to blank of 3. Thus, the number of features decreases from 1836 to 933. That means, about 50% of the features were also detected in the solvent blanks with respect to the above-mentioned settings, and consecutively these features were not reported in the corresponding feature list (export by selecting „height matrix list“ and „blank filter option“).
However, when you look into that feature list, there are still a lot of features in there, which still have average intensity ratios below 3 or even below 1. Approx. 70% of all features belong to that category of features. So in my case, the blank filter process seems not to work properly.

Do you have an idea what the problem might be and how I can get a better feature list?
And a general question, what is meant with „Average Sample Intensity“: the average intensities from all sample files, but including or excluding QC samples?

By the way, I used MS-DIAL version 4.24.

Thanks for your response.
Falco

Re: (Post)Alignment Processing - Blank filter option

Reply #1
Hi Falco

sorry, I cannot reproduce your result on my side. Can you share your small data set with me to understand your problem with some experimental slides?

>>but including or excluding QC samples?
QCs are included.

Thanks,

Hiroshi


Re: (Post)Alignment Processing - Blank filter option

Reply #2
Please consider this scenario as well...

http://www.metabolomics-forum.com/index.php?topic=1469.0

You need to check the ID of the peaks, some of them were generated in silico (as explained in the link).

Cheers,
Stefan

Re: (Post)Alignment Processing - Blank filter option

Reply #3
Hi FalcoB,
Did you untick "Keep 'reference matched' metabolite features" and "Keep 'suggested (w/o MS2)' metabolite features" in the alignment tab? In my understanding, if you tick any of these two options, then you will have some match/suggested features kept in the list even though they are in blanks as well. I had the same confusion before, but now, when I untick them, the final list is good now.

Best,
Sukis


 

Re: (Post)Alignment Processing - Blank filter option

Reply #4
Hey Sukis,

I really ticked some of the "Keep..."-Options in the alignment tag. After unticking everything is fine.

At his point, I did not check the gap-filling option. But I will keep the remark by UFZ-Stef regarding gap-filling algorithm in mind.

Thanks for your help.

 

Re: (Post)Alignment Processing - Blank filter option

Reply #5
You are welcome. It's my pleasure to help.
best,
Sukis

Re: (Post)Alignment Processing - Blank filter option

Reply #6
Great that you solved your problem!

But may I occupy this thread by asking almost the same question the other way round.

I am using Ribitol as internal STD (which is not recommended  :) ) and the peak is correctly annotated.

But even if I tick:
Keep identified and annotated metabolites   TRUE
Keep removable features and assign the tag for checking   TRUE

The ISTD does not show up in the final alignment result table. Has anyone experienced the same problem?! I solved this issue by exporting all metabolites and filtering myself, but this can be annoying.

Cheers Stefan