Skip to main content
Topic: MSDial Alignment Not Working (Read 615 times) previous topic - next topic

MSDial Alignment Not Working

Just for reference, I've read this post and tried what's there, to not much success.

I've been trying to process some negative mode lipidomics files using the most recent version of MSDial (I believe we're on 4.60 right now), and I have been consistently running into the same issue over and over again where I get through file processing and right before it completes I get an error message saying that the JointAligner is not working, alignment failed, and that I need to check my ionization mode/polarity settings. This causes me to be unable to look at the results from anything from the first processed file (I'm trying to align around 90 .raw files) and obviously I cannot export the aligned file since there isn't one. I've tried doing file conversion on different PCs (I'm using Thermo .raw files for reference) and that doesn't seem to make much of a difference. The only thing I can maybe figure is that the ABF file converter doesn't like negative mode files? I always have negative mode selected for MS1 and MS2 files during the pre-processing steps, I've checked that numerous times before. I guess another question I might have is if it's possible to do a work around and use mzmL files instead of .raw files for the file converter? I don't believe so but I'm starting to run out of options.

Appreciate any help that anyone can provide.

Re: MSDial Alignment Not Working

Reply #1
Sorry for the late reply, and actually I cannot answer to this issue because I cannot check your raw data.
Sometimes, it is due to that some of raw data are broken or coming from different ionization mode.
If you can finish processing by a part of data files and if you cannot finish processing by another part of data files, there is such a possibility. Also, you can simply check the file size for all the data, and if you find the one having really unexpected file size when compared with other files, try to process files without the file.