Skip to main content
Topic: Error: package ‘metaXCMS’ was built before R 3.0.0 (Read 9618 times) previous topic - next topic

Error: package ‘metaXCMS’ was built before R 3.0.0

Hi all,

When installing metaXCMS as described on the website, I get the following message:

Error: package ‘metaXCMS’ was built before R 3.0.0: please re-install it

I have also tried it on other PC's (including one with a fresh R installation) and got the same error.

Am I doing something wrong?

Thanks!

Robert


*****
> sessionInfo()
R version 3.0.1 (2013-05-16)
Platform: i386-w64-mingw32/i386 (32-bit)

locale:
[1] LC_COLLATE=Dutch_Netherlands.1252  LC_CTYPE=Dutch_Netherlands.1252    LC_MONETARY=Dutch_Netherlands.1252 LC_NUMERIC=C                     
[5] LC_TIME=Dutch_Netherlands.1252   

attached base packages:
[1] stats    graphics  grDevices utils    datasets  methods  base   

other attached packages:
[1] BiocInstaller_1.10.2

loaded via a namespace (and not attached):
[1] tools_3.0.1


****

> traceback()
3: stop(gettextf("package %s was built before R 3.0.0: please re-install it",
      sQuote(pkgname)), call. = FALSE, domain = NA)
2: testRversion(pkgInfo, package, pkgpath)
1: library(metaXCMS)

Re: Error: package ‘metaXCMS’ was built before R 3.0.0

Reply #1
Looks like R 3.0 does not support the packages that were build using R versions < 3.0.
I'll update the binary package (.zip) soon, in the meantime you could try installing it using the source package (.tar.gz).

Re: Error: package ‘metaXCMS’ was built before R 3.0.0

Reply #2
I have the exact same problem  :?

Re: Error: package ‘metaXCMS’ was built before R 3.0.0

Reply #3
I have this same problem.

How do I get it to work? I am also having trouble processing results from the online version of metaXCMS.

Error: package ‘metaXCMS’ was built before R 3.0.0: please re-install it

Re: Error: package ‘metaXCMS’ was built before R 3.0.0

Reply #4
I know there is a thread on this topic, however it is not much help and it looks like it was fixed in 2011 and is beginning to resurface.  I am running R V 3.0.1 and am getting the error "package 'metaXCMS' was built before R 3.0.0: please re-install it" Is there a fix for this?  I did see this"in the meantime you could try installing it using the source package (.tar.gz)" posted by Ralf in July, but I'm not sure what it means.  If you can't tell from the questions, I'm new to this so please forgive my inexperience of the subject.

Daniel

Re: Error: package ‘metaXCMS’ was built before R 3.0.0

Reply #5
Attached is the windows binary of the metaXCMS 0.1.20 package, build with R 3.0.2.

Re: Error: package ‘metaXCMS’ was built before R 3.0.0

Reply #6
Hi Ralf,

The .zip file with the binary seems to be empty (only 45kB). Is this going to be updated?
Regards,

KurtB

Re: Error: package ‘metaXCMS’ was built before R 3.0.0

Reply #7
I don't think there is anything wrong with the zip file. Have you tried installing it ?

Re: Error: package ‘metaXCMS’ was built before R 3.0.0

Reply #8
Yes, I tried but obviously the wrong way, works fine now!
regards,

Kurt

Re: Error: package ‘metaXCMS’ was built before R 3.0.0

Reply #9
Hi Kurt,

I'm facing the same issue with my metaXCMS installation. Could you tell me how you got around this error?

Thanks!

Shareef

Re: Error: package ‘metaXCMS’ was built before R 3.0.0

Reply #10
The newest R is 3.1.1. metaXCMS need the old R, whild xcms need the newest R.
who can help with this problem.

Re: Error: package ‘metaXCMS’ was built before R 3.0.0

Reply #11
Have you tried installing the new build that is linked in this thread ? 

Regards,
Ralf

Re: Error: package ‘metaXCMS’ was built before R 3.0.0

Reply #12
Dear friends,

I have the same error. I tried the old version of R, I tried to re-install.. And anyway it doesn't work.
Who knows the solution of it?
I see a lot of people have the same situation.
Could anybody helps me, please?


Thanks in advance