Skip to main content
Topic: Error (segmentation fault) when launching AnnotateDiffreport (Read 3217 times) previous topic - next topic

Error (segmentation fault) when launching AnnotateDiffreport

Hi everybody,

For some months, we are getting an error (*** caught segfault ***) when we lauch AnnotateDiffreport on our cluster. We have searched many times but we are desperate. Did anybody ever get this bug when launching annotatediffreport?

Thanks in advance :) ,


Mish

Error we get:

*** caught segfault ***
address (nil), cause 'unknown
Traceback:
 1: .Call("BGL_highly_conn_sg", as.integer(nv), as.integer(ne), as.integer(em -    1), as.double(rep(1, ne)), as.integer(sat), as.integer(lldv),    as.integer(ldv), PACKAGE = "RBGL")
 2: highlyConnSG(g)
 3: .local(object, ...)
 4: calcPC.hcs(object, ...)
 5: calcPC.hcs(object, ...)
 6: do.call(method, alist(object, ...))
 7: calcPC(object, method = graphMethod, ajc = resMat, psg_list = psg_list)
 8: calcPC(object, method = graphMethod, ajc = resMat, psg_list = psg_list)
 9: .local(object, cor_eic_th, pval, graphMethod, calcIso, calcCiS,    calcCaS, psg_list, xraw, cor_exp_th, ...)
10: groupCorr(xa, cor_eic_th = cor_eic_th, psg_list = psg_list)
11: groupCorr(xa, cor_eic_th = cor_eic_th, psg_list = psg_list)
12: annotateDiffreport(<S4 object of class "xcmsSet">, eicmax = 10,    eicwidth = 200, metlin = 0, sortpval = "TRUE", nSlaves = 9,    sigma = 6, perfwhm = 0.6, maxcharge = 3, maxiso = 4, minfrac = 0.5,    ppm = 5, mzabs = 0.015, quick = "FALSE", cor_eic_th = 0.75,    graphMethod = "hcs", pval = 0.05, calcCiS = "TRUE", calcIso = "FALSE",    calcCaS = "FALSE", polarity = "negative", multiplier = 3,    class1 = "Urines_Controles_A", class2 = "Urines_Controles_B",    filebase = "Urines_Controles_A_vs_Urines_Controles_B")
13: do.call(thefunction, listArguments)

Re: Error (segmentation fault) when launching AnnotateDiffre

Reply #1
This problem has nothing to do with CAMERA, but with highlyConnSG() in the RBGL library.
Can you try updating/reinstalling RBGL ?

Re: Error (segmentation fault) when launching AnnotateDiffre

Reply #2
Hi,

Thank you very much for your advice, you are right, i updated the RGBL package and it solved my problem.

Thank you again,

Cheers,

Misharl Monsoor.